Docs & RFCs to read
37 items
Log in to save your progress.
RFC 791 – IPv4
Networking
RFC 8200 – IPv6
Networking
RFC 9293 – TCP
Networking · starter pack
RFC 768 – UDP
Networking
RFC 1122/1123 – Host Requirements
Networking
RFC 1034 – DNS Concepts & Facilities
DNS · starter pack
RFC 1035 – DNS Implementation & Specification
DNS
RFC 2308 – Negative Caching of DNS Queries
DNS
RFC 1912 – Common DNS Operational and Configuration Errors
DNS
RFC 9110 – HTTP Semantics
HTTP · starter pack
RFC 9111 – HTTP Caching
HTTP
RFC 9112 – HTTP/1.1
HTTP
RFC 7540 – HTTP/2
HTTP
RFC 8446 – TLS 1.3
Security · starter pack
RFC 5280 – X.509 Certificates + PKI
Security
RFC 5321 – SMTP
Email
RFC 5322 – Internet Message Format
Email
RFC 6376 – DKIM
Email
RFC 7208 – SPF
Email
RFC 7489 – DMARC
Email
RFC 6749 – OAuth 2.0
Identity · starter pack
RFC 6750 – Bearer Tokens
Identity
RFC 7636 – PKCE
Identity
RFC 7519 – JWT
Identity
RFC 3339 – Date and Time on the Internet
Time · starter pack
RFC 4086 – Randomness Requirements for Security
Security
Vite docs
TypeScript docs (tsconfig)
Svelte docs
Node.js docs
Bun docs
shadcn/ui docs
AWS docs
Google Cloud docs
ESLint docs
JSCore docs
Cloudflare docs